Разлика между версии на „Use repositories of InfoNotary“

от Infonotary
Направо към: навигация, търсене
Ред 1: Ред 1:
 
For your convenience InfoNotary offers repositories with deb and rpm packages for software that is not open source.
 
For your convenience InfoNotary offers repositories with deb and rpm packages for software that is not open source.
 
[[Image:warning.jpg|32px]] The following commands must be entered in terminal. You can read what is terminal and hot to use it in [https://help.ubuntu.com/community/UsingTheTerminal Ubuntu documentation] or in [http://askubuntu.com/a/38220 answer in askubuntu].
 
  
 
== For Fedora, RedHat or CentOS ==
 
== For Fedora, RedHat or CentOS ==
1. Add public PGP key of InfoNotary:
+
<!--1. Add public PGP key of InfoNotary:
 
{{Шаблон:ConsoleOutput|su<br/>
 
{{Шаблон:ConsoleOutput|su<br/>
 
rpm --import http://repository.infonotary.com/install/linux/INotaryCodeSigning.key.asc}}
 
rpm --import http://repository.infonotary.com/install/linux/INotaryCodeSigning.key.asc}}
Ред 12: Ред 10:
 
<br/>
 
<br/>
 
[[Image:warning.jpg|32px]] Tested on Fedora 10+.
 
[[Image:warning.jpg|32px]] Tested on Fedora 10+.
<br/><br/>
+
<br/><br/>-->
 +
To register InfoNotary repository in yum or dnf you must install this [http://repository.infonotary.com/install/linux/RPMS/infonotary-repository-1-1.noarch.rpm rpm package] with the following command from terminal:
 +
{{Шаблон:ConsoleOutput|sudo rpm -Uvh http://repository.infonotary.com/install/linux/RPMS-test/infonotary-repository-1-1.noarch.rpm}}
 +
 
 +
All packages are signed with gpg key with following fingerprint:
 +
:'''9c14 29cf 1cdb 76bd 5efe 9cf1 ade8 9959 0dae 44fe'''.
  
 
== For Debian, Ubuntu and Mint ==
 
== For Debian, Ubuntu and Mint ==
 +
The following commands must be entered in terminal. You can read what is terminal and hot to use it in [https://help.ubuntu.com/community/UsingTheTerminal Ubuntu documentation] or in [http://askubuntu.com/a/38220 answer in askubuntu].
 +
 
1. Add InfoNotary public PGP key to the list of trusted APT keys:
 
1. Add InfoNotary public PGP key to the list of trusted APT keys:
 
{{Шаблон:ConsoleOutput|wget -qO - http://repository.infonotary.com/install/linux/INotaryCodeSigning.key.asc | sudo apt-key add -}}
 
{{Шаблон:ConsoleOutput|wget -qO - http://repository.infonotary.com/install/linux/INotaryCodeSigning.key.asc | sudo apt-key add -}}
 
  
 
2. Download repository configuration file in apt configuration directory:
 
2. Download repository configuration file in apt configuration directory:
 
{{Шаблон:ConsoleOutput|sudo wget http://repository.infonotary.com/install/linux/infonotary.list -qO /etc/apt/sources.list.d/infonotary.list}}
 
{{Шаблон:ConsoleOutput|sudo wget http://repository.infonotary.com/install/linux/infonotary.list -qO /etc/apt/sources.list.d/infonotary.list}}
 
  
 
3. Update information for repositories with the following command:
 
3. Update information for repositories with the following command:

Версия от 12:17, 26 юли 2017

For your convenience InfoNotary offers repositories with deb and rpm packages for software that is not open source.

For Fedora, RedHat or CentOS

To register InfoNotary repository in yum or dnf you must install this rpm package with the following command from terminal:

sudo rpm -Uvh http://repository.infonotary.com/install/linux/RPMS-test/infonotary-repository-1-1.noarch.rpm

All packages are signed with gpg key with following fingerprint:

9c14 29cf 1cdb 76bd 5efe 9cf1 ade8 9959 0dae 44fe.

For Debian, Ubuntu and Mint

The following commands must be entered in terminal. You can read what is terminal and hot to use it in Ubuntu documentation or in answer in askubuntu.

1. Add InfoNotary public PGP key to the list of trusted APT keys:

wget -qO - http://repository.infonotary.com/install/linux/INotaryCodeSigning.key.asc

2. Download repository configuration file in apt configuration directory:

sudo wget http://repository.infonotary.com/install/linux/infonotary.list -qO /etc/apt/sources.list.d/infonotary.list

3. Update information for repositories with the following command:

sudo apt-get update


Warning.jpg Tested on Ubuntu 9.04+.