Разлика между версии на „Installation of smart card reader and smart card drivers in macOS“

От Infonotary
Направо към: навигация, търсене
(Driver for readers)
Ред 16: Ред 16:
 
[[Картинка:ACR_38T.png]]
 
[[Картинка:ACR_38T.png]]
  
If the your reader is labeled with '''ACR38C-SPC-R''' at the bottom, have a sign '''SIMLector 38T''' on the inside or a sign '''mLector-S''', then your device works with the build in driver in the OS and you don't have to install any drivers.
+
If the your reader is labeled with '''ACR38C-SPC-R''', '''mLector-S''' or '''ACR39T''' at the bottom, then your device works with the build in driver in the OS and you don't have to install any drivers.
  
=== ACR 38U ===
+
<!--=== ACR 38U ===
 
[[Картинка:ACR_38U.png]]
 
[[Картинка:ACR_38U.png]]
  
Reader that are labeled ACR 38U,are not compatible with this driver, so if you use such a device you have to install driver from the [http://www.acs.com.hk/drivers-manual.php?driver=ACR38 site of the manifactorer].
+
Reader that are labeled ACR 38U,are not compatible with this driver, so if you use such a device you have to install driver from the [http://www.acs.com.hk/drivers-manual.php?driver=ACR38 site of the manifactorer].-->
  
 
=== Omnikey (HID Global) ===
 
=== Omnikey (HID Global) ===
Ред 28: Ред 28:
  
 
For you to use OmniKey CardMan, you have to install the driver from HID Global for your version of OS X:
 
For you to use OmniKey CardMan, you have to install the driver from HID Global for your version of OS X:
 +
* [http://repository.infonotary.com/drivers/HIDGlobal/OmniKey-Installer-4.1.8.dmg Driver for 10.11 - 10.15].
 
* [http://repository.infonotary.com/drivers/HIDGlobal/ifdokccid_mac_universal-v4.1.8.dmg Driver for 10.6 - 10.10].
 
* [http://repository.infonotary.com/drivers/HIDGlobal/ifdokccid_mac_universal-v4.1.8.dmg Driver for 10.6 - 10.10].
* [http://repository.infonotary.com/drivers/HIDGlobal/OmniKey-Installer-4.1.8.dmg Driver for 10.11 El Capitan].
+
 
  
 
[[Image:WarningYellow.png|32px]] After update of the OS X you have to install the drivers again.
 
[[Image:WarningYellow.png|32px]] After update of the OS X you have to install the drivers again.
Ред 40: Ред 41:
 
In OS X 10.10 Yosemite this readder is supported by Apple driver, so there is no need to install another driver.
 
In OS X 10.10 Yosemite this readder is supported by Apple driver, so there is no need to install another driver.
  
=== Todos ===
+
<!--=== Todos ===
 
[[Картинка:TodosArgusMiniII.gif]]
 
[[Картинка:TodosArgusMiniII.gif]]
  
 
To use Todos Argos Mini II you have to install the driver. Depends on what version of Mac OS X you use install the following:
 
To use Todos Argos Mini II you have to install the driver. Depends on what version of Mac OS X you use install the following:
 
* [http://support.gemalto.com/fileadmin/user_upload/drivers/Todos/Argos_Mini_II/AGMII_MAC/AgmIIMac_v1_1_0_0_OSX_10_6.zip Driver for Mac OS X 10.6]
 
* [http://support.gemalto.com/fileadmin/user_upload/drivers/Todos/Argos_Mini_II/AGMII_MAC/AgmIIMac_v1_1_0_0_OSX_10_6.zip Driver for Mac OS X 10.6]
* [http://support.gemalto.com/fileadmin/user_upload/drivers/Todos/Argos_Mini_II/AGMII_MAC/AgmIIMac_OSX_10_5.zip Driver for Mac OS X 10.5]
+
* [http://support.gemalto.com/fileadmin/user_upload/drivers/Todos/Argos_Mini_II/AGMII_MAC/AgmIIMac_OSX_10_5.zip Driver for Mac OS X 10.5]-->
  
 
== Install Smart Card driver ==
 
== Install Smart Card driver ==
  
Depend of the model of your card you have to use different software. The model of the card is on the Personal Access Rights, which you receive with your card. In case your model is „'''T&S DS/2048 (L)'''“, you have to install [[#Install Bit4id Universal Middleware|Bit4id Universal Middleware]] from you installation CD. If the model is „'''CardOS V4.3B (C)'''“, you have to install [[#Download and install OpenSC|OpenSC]].
+
Depend of the model of your card you have to use different software. The model of the card is on the Personal Access Rights, which you receive with your card. In case your model is „'''T&S DS/2048 (L)'''“, you have to install [[#Install Bit4id Universal Middleware|Bit4id Universal Middleware]]. If the model is „'''CardOS V4.3B (C)'''“, you have to install [[#Download and install OpenSC|OpenSC]].
  
 
Incase you dont have Personal Access Rights, you can check your card model with this command {{Шаблон:Console|pcsctest}} from terminal. She will ask you for the reader number, you have to press 1. If there is no problem with the reader installation you will get a row beginning with „Current Reader ATR Value“. Against this text is an indetifier for the card.
 
Incase you dont have Personal Access Rights, you can check your card model with this command {{Шаблон:Console|pcsctest}} from terminal. She will ask you for the reader number, you have to press 1. If there is no problem with the reader installation you will get a row beginning with „Current Reader ATR Value“. Against this text is an indetifier for the card.
Ред 56: Ред 57:
  
 
=== Installation of Bit4id Universal Middleware ===
 
=== Installation of Bit4id Universal Middleware ===
To use Bit4id on Mac OS X, you must install Bit4id Universal Middleware. You can find it on the installation CD, in folder Install/MacOSX. to work with  Firefox и Thunderbird, you have to install Bit4id Cryptoki Libraries 1.2.12.pkg, and for integration with the OS and the other programs for Mac OS X - bit4id-tokend-ts-en-1.2.9.0.pkg.dmg.
+
<!--To use Bit4id on Mac OS X, you must install Bit4id Universal Middleware. You can find it on the installation CD, in folder Install/MacOSX. to work with  Firefox и Thunderbird, you have to install Bit4id Cryptoki Libraries 1.2.12.pkg, and for integration with the OS and the other programs for Mac OS X - bit4id-tokend-ts-en-1.2.9.0.pkg.dmg.
<!--
+
 
 
[http://repository.infonotary.com/install/mac/Bit4id-Cryptoki-Libraries-1.2.13.pkg Bit4id-Cryptoki-Libraries]
 
[http://repository.infonotary.com/install/mac/Bit4id-Cryptoki-Libraries-1.2.13.pkg Bit4id-Cryptoki-Libraries]
 
[http://repository.infonotary.com/install/mac/bit4id-tokend-ts-en-1.2.9.0.pkg.dmg bit4id-tokend-ts]
 
[http://repository.infonotary.com/install/mac/bit4id-tokend-ts-en-1.2.9.0.pkg.dmg bit4id-tokend-ts]
 
-->
 
-->
 +
 +
Please write to support@infonotary.com , and we will send you the drivers.
  
 
In case you have to register the PKCS#11 module на Bit4id in a program different from Firefox, Thunderbird or InfoNotary Smart Card Manager you have to specify a path - /System/Library/bit4id/cryptoki/libbit4ipki.dylib.
 
In case you have to register the PKCS#11 module на Bit4id in a program different from Firefox, Thunderbird or InfoNotary Smart Card Manager you have to specify a path - /System/Library/bit4id/cryptoki/libbit4ipki.dylib.
Ред 66: Ред 69:
 
After the installation continue with configuration [[Using your digital signature with Firefox on MAC OS X |Firefox]] or [[Install Infonotary Certificate Chain on Mac OS X |Safari]].
 
After the installation continue with configuration [[Using your digital signature with Firefox on MAC OS X |Firefox]] or [[Install Infonotary Certificate Chain on Mac OS X |Safari]].
  
'''Note:''' In case you didn't receive a CD or your laptop doesn't have a CD drive, please write to support@infonotary.com , and we will send you the drivers.
+
 
  
 
=== Download and install OpenSC ===
 
=== Download and install OpenSC ===

Версия от 11:35, 13 октомври 2020

General

In several places in this instruction you have to run a command in Terminal. You can start Terminal from Applications/Utilities or you can write Terminal in Spotlight.

The text writen this way are commands, which you have to run in Terminal. You dont have to write them just copy them with the clipboard. To work correctly commands which starts with sudo,is nessesary for you to have a password for the user. If you don't have set a temporary one during the settings. After you use one of the commands you will be propted for password.

What is nessesary to work with digital signature

In order to use your digital sigature is nessesary to install the driver for the smart card reader, the middleware for the smart card and the service for smart card resders (pcscd) running. The service pcscd must start automatically when you plug a reader.

System requerments

The software requered to work with certificates on Mac, supports Mac OS X 10.5 or newer.

Support for 10.5 is paritial. All needed drivers work on 10.5 but InfoNotary software for signing of documents and card management does not.

Driver for readers

ACR 38C

ACR 38T.png

If the your reader is labeled with ACR38C-SPC-R, mLector-S or ACR39T at the bottom, then your device works with the build in driver in the OS and you don't have to install any drivers.


Omnikey (HID Global)

CardMan6121.gifCardMan3021.png

For you to use OmniKey CardMan, you have to install the driver from HID Global for your version of OS X:


WarningYellow.png After update of the OS X you have to install the drivers again.

Bit4id miniLector-S

If your reader is labeled with miniLector-S you must install this driver - driver for miniLector-S for OS X from 10.6 to 10.9 inclusive.

In OS X 10.10 Yosemite this readder is supported by Apple driver, so there is no need to install another driver.


Install Smart Card driver

Depend of the model of your card you have to use different software. The model of the card is on the Personal Access Rights, which you receive with your card. In case your model is „T&S DS/2048 (L)“, you have to install Bit4id Universal Middleware. If the model is „CardOS V4.3B (C)“, you have to install OpenSC.

Incase you dont have Personal Access Rights, you can check your card model with this command pcsctest from terminal. She will ask you for the reader number, you have to press 1. If there is no problem with the reader installation you will get a row beginning with „Current Reader ATR Value“. Against this text is an indetifier for the card.

  • For T&S DS/2048 the indentidier is „3B FF 18 00 FF 81 31 FE 55 00 6B 02 09 03 03 01 11 01 43 4E 53 11 31 80 8C“.
  • For CardOS V4.3 the indentidier is „3B F2 18 00 02 C1 0A 31 FE 58 C8 08 74“.

Installation of Bit4id Universal Middleware

Please write to support@infonotary.com , and we will send you the drivers.

In case you have to register the PKCS#11 module на Bit4id in a program different from Firefox, Thunderbird or InfoNotary Smart Card Manager you have to specify a path - /System/Library/bit4id/cryptoki/libbit4ipki.dylib.

After the installation continue with configuration Firefox or Safari.


Download and install OpenSC

To use your certificate on OSX you must install OpenSC. With OpenSС you dont install any program with graphic interface so you wont find anything in Applications. You can download the latest version for your OS from here:

In case you have to register the PKCS#11 module на Bit4id in a program different from Firefox, Thunderbird or InfoNotary Smart Card Manager you have to specify a path - /Library/OpenSC/lib/onepin-opensc-pkcs11.so.

After the installation continue with configuration Testing Installation or Firefox and Safari.

Use both OpenSC and Bit4id Universal Middleware

In case you want to use both OpenSC and Bit4id Universal Middleware on the same computer you have to forbid OpenSC to access T&S DS/2048 smart cards. The easiest way to do it is to use following program:

Disable Bit4id cards in OpenSC.

If you prefer to do it manually you can find instructions on OpenSC page.

Testing Installation

If you have problem using your certificate, you can run the following program to identify it:

It can send information directly to us. After report is accepted, it will show nine digit number, that can be used by our support team to see test result. If you do not have Internet connection or direct sending failed, you can save report and send it to support@infonotary.com.

Reader and card should be connected to the computer when test program is started.

Uninstall

OpenSC can be uninstalled with this program - OpenSC uninstaller.

Bit4id Universal Middleware can be uninstaled, by running the program Uninstaller from the folder /System/Library/bit4id.

Documentation

Documentation for OpenSC is available on Internet or in folder /Library/OpenSC/doc/ after the installation.

On the page Working with OpenSC you can find instruction for th most common operation with OpenSC.