Разлика между версии на „Използване на квалифициран електронен подпис в Google Chrome/Chromium за Linux“

От Infonotary
Направо към навигацията Направо към търсенето
(Не са показани 32 междинни версии от същия потребител)
Ред 1: Ред 1:
 
== Преди да пристъпите към изпълнение ==
 
== Преди да пристъпите към изпълнение ==
  
Ако притежавате смарт карта и четец от Инфонотари, но не сте инсталирали драйвери за тях, изпълнете инструкциите от [[Инсталация на драйвери за четец и смарт карта в Linux]].
+
Ако притежавате смарт карта и четец от Инфонотари, но не сте инсталирали драйвери за тях, изпълнете инструкциите от [[Използване на хранилищата на InfoNotary]].
  
 
{{Шаблон:Mozilla_warning|Google Chrome}}
 
{{Шаблон:Mozilla_warning|Google Chrome}}
Ред 8: Ред 8:
 
Преди да започнете работа с Вашето удостоверение за електронен подпис, е необходимо да изтеглите [https://infonotary.com/files/InfoNotary_Qualified_eIDAS.p12 базовите удостоверения на Инфонотари].
 
Преди да започнете работа с Вашето удостоверение за електронен подпис, е необходимо да изтеглите [https://infonotary.com/files/InfoNotary_Qualified_eIDAS.p12 базовите удостоверения на Инфонотари].
  
* За самата инсталация стартирайте Chrome, отворете настройките му и натиснете линка „Показване на разширените настройки...". Натиснете бутона „Управление на сертификати..." в секцията HTTPS/SSL за да се отвори „Диспечер на сертификати“ като на снимката:
+
* За самата инсталация стартирайте Chrome, отворете '''Settings > Privacy and security > Security > Manage certificates '''
  
[[Картинка:Chrome-certs-empty.png]]
+
* Изберете секцията "'''Your certificates'''", натиснете бутон "'''Import'''" и посочете пътя до предварително изтеглената удостоверителната верига – [https://infonotary.com/files/InfoNotary_Qualified_eIDAS.p12 InfoNotary_Qualified_eIDAS.p12].
  
* Изберете секцията „Вашите сертификати", както е показано на картинката, натиснете бутона „Импортиране..." и посочете пътя до инсталационния файл на удостоверителната верига – [https://infonotary.com/files/InfoNotary_Qualified_eIDAS.p12 InfoNotary_Qualified_eIDAS.p12]. След това ще бъдете попитани за парола на файла. Оставете полето празно и натиснете OK.
+
След това ще бъдете попитани за парола на файла. Оставете полето празно и натиснете OK.
  
* За всяко базово удостоверение на удостоверяващ орган потребителят трябва да избере ниво на доверие. Това става чрез избор на удостоверение и натискане на бутона „Редактиране...". Списъка с инсталираните базови удостоверения може да видите в раздела „Органи“:
+
[[Файл:ChromeLinux1.png|750px]]
  
[[Картинка:Chrome-authorities.png]]
 
  
Най-лесният начин да направите тази настройка е като за удостоверението '''InfoNotary TSP Root''' изберете и трите опции, както е показано:
 
  
[[Картинка:Chrome-trust.png]]
+
* От раздел "'''Authorities'''" потърсете '''InfoNotary TSP Root''' и натиснете бутон "'''Edit'''"
 +
[[Файл:ChromeLinux2.png|750px]]
 +
 
 +
* Маркирайте и трите отметки, както е показано:
 +
 
 +
[[Файл:ChromeLinux3.png|550px]]
  
 
== Регистриране на хардуерен криптографски модул ==
 
== Регистриране на хардуерен криптографски модул ==
Ред 26: Ред 29:
 
* След като сте инсталирали базовите удостоверения, трябва да настроите програмата да използва PKCS#11 модула от драйвера на картата. Понеже Chrome няма интерфейс за добавянето на криптографски модули, трябва да се използва следният метод:
 
* След като сте инсталирали базовите удостоверения, трябва да настроите програмата да използва PKCS#11 модула от драйвера на картата. Понеже Chrome няма интерфейс за добавянето на криптографски модули, трябва да се използва следният метод:
  
# Инсталирайте инструментите за работа с NSS. В Debian и базираните на него дистрибуции пакетът е '''libnss3-tools'''.
+
# Инсталирайте инструментите за работа с NSS. В Debian и базираните на него дистрибуции пакетът е '''libnss3-tools'''
 
# Спрете Chrome и изключете четеца от компютъра.
 
# Спрете Chrome и изключете четеца от компютъра.
 
# Създайте директорията за базата данни на NSS със следната команда - {{Шаблон:Console|mkdir -p $HOME/.pki/nssdb}}
 
# Създайте директорията за базата данни на NSS със следната команда - {{Шаблон:Console|mkdir -p $HOME/.pki/nssdb}}
 
# От терминал изпълнете следната команда:
 
# От терминал изпълнете следната команда:
* за OpenSC - {{Шаблон:Console|modutil -add "OpenSC" -libfile opensc-pkcs11.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY}}<br/>  
+
* за '''Bit4ID''' - {{Шаблон:Console|modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY}}<br/>
* за Bit4ID - {{Шаблон:Console|modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY}}<br/>
+
* за '''OpenSC''' - {{Шаблон:Console|modutil -add "OpenSC" -libfile one-opensc-pkcs11.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY}}<br/>  
 
В случай че използвате драйвер на Siemens, библиотеката е libsiecap11.so, съответно името може да е Siemens.
 
В случай че използвате драйвер на Siemens, библиотеката е libsiecap11.so, съответно името може да е Siemens.
  
Ред 37: Ред 40:
 
Включете четеца в компютъра и стартирайте Chrome.
 
Включете четеца в компютъра и стартирайте Chrome.
  
* След като стартирате Chrome, ще можете да видите удостоверенията от картата в настройките за лични сертификати и съответно да ги използвате за вход в сайтовете изискващи КЕП.
+
* След като стартирате Chrome, ще можете да видите удостоверенията от картата в настройките и съответно да ги използвате за вход в сайтовете изискващи КЕП.
 +
 
  
 +
'''Пример за добавяне на Bit4ID модул:'''
  
 
<pre>
 
<pre>
skk@skk:~$ sudo apt-get install libnss3-tools
+
* skk@skk:~$ sudo apt-get install libnss3-tools
  
 
Reading package lists... Done
 
Reading package lists... Done
 
Building dependency tree... Done
 
Building dependency tree... Done
 
Reading state information... Done
 
Reading state information... Done
The following packages were automatically installed and are no longer required:
 
  chromium-codecs-ffmpeg-extra gstreamer1.0-vaapi i965-va-driver
 
  intel-media-va-driver libaacs0 libaom0 libass9 libavcodec58 libavformat58
 
  libavutil56 libbdplus0 libblas3 libbluray2 libbs2b0 libchromaprint1
 
  libcodec2-0.9 libdav1d4 libfftw3-double3 libflite1 libgme0 libgsm1
 
  libgstreamer-plugins-bad1.0-0 libigdgmm11 liblilv-0-0 libmfx1 libmysofa1
 
  libnorm1 libopenmpt0 libpgm-5.3-0 libpostproc55 librabbitmq4 librubberband2
 
  libserd-0-0 libshine3 libsnappy1v5 libsord-0-0 libsratom-0-0
 
  libsrt1.4-gnutls libssh-gcrypt-4 libswresample3 libswscale5 libudfread0
 
  libva-drm2 libva-wayland2 libva-x11-2 libva2 libvdpau1 libvidstab1.1
 
  libx265-192 libxvidcore4 libzmq5 libzvbi-common libzvbi0 mesa-va-drivers
 
  mesa-vdpau-drivers opensc-pkcs11 pocketsphinx-en-us va-driver-all
 
  vdpau-driver-all
 
Use 'sudo apt autoremove' to remove them.
 
 
The following NEW packages will be installed:
 
The following NEW packages will be installed:
 
   libnss3-tools
 
   libnss3-tools
Ред 66: Ред 57:
 
After this operation, 5046 kB of additional disk space will be used.
 
After this operation, 5046 kB of additional disk space will be used.
 
Selecting previously unselected package libnss3-tools.
 
Selecting previously unselected package libnss3-tools.
(Reading database ... 187590 files and directories currently installed.)
+
(Reading database ... 187133 files and directories currently installed.)
 
Preparing to unpack .../libnss3-tools_2%3a3.61-1ubuntu2_amd64.deb ...
 
Preparing to unpack .../libnss3-tools_2%3a3.61-1ubuntu2_amd64.deb ...
 
Unpacking libnss3-tools (2:3.61-1ubuntu2) ...
 
Unpacking libnss3-tools (2:3.61-1ubuntu2) ...
Ред 72: Ред 63:
 
Processing triggers for man-db (2.9.4-2) ...
 
Processing triggers for man-db (2.9.4-2) ...
  
skk@skk:~$ mkdir -p $HOME/.pki/nssdb
+
 
skk@skk:~$ modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY
+
* skk@skk:~$ mkdir -p $HOME/.pki/nssdb
 +
* skk@skk:~$ modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY
  
 
WARNING: Performing this operation while the browser is running could cause
 
WARNING: Performing this operation while the browser is running could cause
Ред 82: Ред 74:
 
Module "Bit4id" added to database.
 
Module "Bit4id" added to database.
  
 +
 +
</pre>
 +
 +
 +
''' Може да проверите добавените модули с команда'''
 +
 +
{{Шаблон:Console|modutil -dbdir sql:$HOME/.pki/nssdb -list}}<br/>
 +
 +
'''Пример:'''
 +
<pre>
 +
* skk@skk:~$ modutil -dbdir sql:$HOME/.pki/nssdb -list
 +
 +
Listing of PKCS #11 Modules
 +
-----------------------------------------------------------
 +
  1. NSS Internal PKCS #11 Module
 +
  uri: pkcs11:library-manufacturer=Mozilla%20Foundation;library-description=NSS%20Internal%20Crypto%20Services;library-version=3.61
 +
slots: 2 slots attached
 +
status: loaded
 +
 +
slot: NSS Internal Cryptographic Services
 +
token: NSS Generic Crypto Services
 +
  uri: pkcs11:token=NSS%20Generic%20Crypto%20Services;manufacturer=Mozilla%20Foundation;serial=0000000000000000;model=NSS%203
 +
 +
slot: NSS User Private Key and Certificate Services
 +
token: NSS Certificate DB
 +
  uri: pkcs11:token=NSS%20Certificate%20DB;manufacturer=Mozilla%20Foundation;serial=0000000000000000;model=NSS%203
 +
 +
  2. Bit4id
 +
library name: libbit4ipki.so
 +
  uri: pkcs11:library-manufacturer=bit4id%20srl;library-description=bit4id%20PKCS%2311;library-version=1.2
 +
slots: There are no slots attached to this module
 +
status: loaded
 +
-----------------------------------------------------------
 +
 +
</pre>
 +
 +
'''При необходимост може да изтриете даден модул със същата команда с която сте го внесли, като трябва да промените -add с -delete'''
 +
 +
{{Шаблон:Console|modutil '''-delete''' "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY}}<br/>
 +
 +
'''Пример:'''
 +
 +
<pre>
 +
* skk@skk:~$ modutil -delete "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY
 +
WARNING: Performing this operation while the browser is running could cause
 +
corruption of your security databases. If the browser is currently running,
 +
you should exit browser before continuing this operation. Type
 +
'q <enter>' to abort, or <enter> to continue:
 +
 +
Module "Bit4id" deleted from database.
  
 
</pre>
 
</pre>

Версия от 13:21, 11 май 2022

Преди да пристъпите към изпълнение

Ако притежавате смарт карта и четец от Инфонотари, но не сте инсталирали драйвери за тях, изпълнете инструкциите от Използване на хранилищата на InfoNotary.

  • ВАЖНО: При използването на смарт картата с Google Chrome се използва директен достъп до смарт картата, а не хранилище за удостоверенията. Когато успешно сте инсталирали удостоверенията си, НЕ ТРЯБВА да ги триете оттам, тъй като това ще доведе и до изтриване на удостоверението, заедно с частния и публичния ключ от смарт картата. След това удостоверението не може да се възстанови и трябва да се издаде ново.
  • ВАЖНО: За да може да ползвате удостоверението си за електронен подпис с Google Chrome, е задължително четецът да е включен в компютъра, преди да пуснете самата програма.


Инсталиране на удостоверителната верига на Инфонотари

Преди да започнете работа с Вашето удостоверение за електронен подпис, е необходимо да изтеглите базовите удостоверения на Инфонотари.

  • За самата инсталация стартирайте Chrome, отворете Settings > Privacy and security > Security > Manage certificates
  • Изберете секцията "Your certificates", натиснете бутон "Import" и посочете пътя до предварително изтеглената удостоверителната верига – InfoNotary_Qualified_eIDAS.p12.

След това ще бъдете попитани за парола на файла. Оставете полето празно и натиснете OK.

ChromeLinux1.png


  • От раздел "Authorities" потърсете InfoNotary TSP Root и натиснете бутон "Edit"

ChromeLinux2.png

  • Маркирайте и трите отметки, както е показано:

ChromeLinux3.png

Регистриране на хардуерен криптографски модул

  • След като сте инсталирали базовите удостоверения, трябва да настроите програмата да използва PKCS#11 модула от драйвера на картата. Понеже Chrome няма интерфейс за добавянето на криптографски модули, трябва да се използва следният метод:
  1. Инсталирайте инструментите за работа с NSS. В Debian и базираните на него дистрибуции пакетът е libnss3-tools
  2. Спрете Chrome и изключете четеца от компютъра.
  3. Създайте директорията за базата данни на NSS със следната команда - mkdir -p $HOME/.pki/nssdb
  4. От терминал изпълнете следната команда:
  • за Bit4ID - modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY
  • за OpenSC - modutil -add "OpenSC" -libfile one-opensc-pkcs11.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY

В случай че използвате драйвер на Siemens, библиотеката е libsiecap11.so, съответно името може да е Siemens.


Включете четеца в компютъра и стартирайте Chrome.

  • След като стартирате Chrome, ще можете да видите удостоверенията от картата в настройките и съответно да ги използвате за вход в сайтовете изискващи КЕП.


Пример за добавяне на Bit4ID модул:

* skk@skk:~$ sudo apt-get install libnss3-tools

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
The following NEW packages will be installed:
  libnss3-tools
0 upgraded, 1 newly installed, 0 to remove and 4 not upgraded.
Need to get 0 B/1021 kB of archives.
After this operation, 5046 kB of additional disk space will be used.
Selecting previously unselected package libnss3-tools.
(Reading database ... 187133 files and directories currently installed.)
Preparing to unpack .../libnss3-tools_2%3a3.61-1ubuntu2_amd64.deb ...
Unpacking libnss3-tools (2:3.61-1ubuntu2) ...
Setting up libnss3-tools (2:3.61-1ubuntu2) ...
Processing triggers for man-db (2.9.4-2) ...


* skk@skk:~$ mkdir -p $HOME/.pki/nssdb
* skk@skk:~$ modutil -add "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY

WARNING: Performing this operation while the browser is running could cause
corruption of your security databases. If the browser is currently running,
you should exit browser before continuing this operation. Type 
'q <enter>' to abort, or <enter> to continue: 

Module "Bit4id" added to database.



Може да проверите добавените модули с команда

modutil -dbdir sql:$HOME/.pki/nssdb -list

Пример:

* skk@skk:~$ modutil -dbdir sql:$HOME/.pki/nssdb -list

Listing of PKCS #11 Modules
-----------------------------------------------------------
  1. NSS Internal PKCS #11 Module
	   uri: pkcs11:library-manufacturer=Mozilla%20Foundation;library-description=NSS%20Internal%20Crypto%20Services;library-version=3.61
	 slots: 2 slots attached
	status: loaded

	 slot: NSS Internal Cryptographic Services
	token: NSS Generic Crypto Services
	  uri: pkcs11:token=NSS%20Generic%20Crypto%20Services;manufacturer=Mozilla%20Foundation;serial=0000000000000000;model=NSS%203

	 slot: NSS User Private Key and Certificate Services
	token: NSS Certificate DB
	  uri: pkcs11:token=NSS%20Certificate%20DB;manufacturer=Mozilla%20Foundation;serial=0000000000000000;model=NSS%203

  2. Bit4id
	library name: libbit4ipki.so
	   uri: pkcs11:library-manufacturer=bit4id%20srl;library-description=bit4id%20PKCS%2311;library-version=1.2
	 slots: There are no slots attached to this module
	status: loaded
-----------------------------------------------------------

При необходимост може да изтриете даден модул със същата команда с която сте го внесли, като трябва да промените -add с -delete

modutil -delete "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY

Пример:

* skk@skk:~$ modutil -delete "Bit4id" -libfile libbit4ipki.so -dbdir sql:$HOME/.pki/nssdb -mechanisms FRIENDLY 
WARNING: Performing this operation while the browser is running could cause
corruption of your security databases. If the browser is currently running,
you should exit browser before continuing this operation. Type 
'q <enter>' to abort, or <enter> to continue: 

Module "Bit4id" deleted from database.