Настройка на браузъра за работа в Търговския регистър

от Infonotary
Направо към: навигация, търсене

Инсталиране на Java

За да може да работите в Търговския регистър е необходимо да имате инсталирана Java и да ползвате браузър, който поддържа Java plugin. Това са всички популярни браузъри без Chrome, Opera и Microsoft Edge. Най-новата версия на Java може да изтеглите и инсталирате от сайта на Java. При инсталация или ъпдейт на Java с версия 7 update 51 или по-нова е необходимо да влезнете в Control Panel оттам изберете Java.

JAVA21.JPG]

Излиза прозорец Java Control Panel, от който изберете Security и отбележете нивото на защита на Medium.

JAVA.JPG]

Натиснете Apply и ОК.

Проблема и решението се отнасят за всички сайтове използващи Java.

Зареждане на PKCS#11 библиотеки

Когато искате да подпишете нещо в Търговския регистър, Java се активира и иска достъп до Вашата смарт карта, чрез така наречените библиотеки.

Ако пътят към библиотеките е стандартен, трябва да се появят автоматично. Ако не се виждат, е необходимо да се заредят ръчно.

Това са библиотеки за картите, предлагани от Инфонотари:


За Windows:

Siemens - C:\WINDOWS\system32\siecap11.dll

Charismathics - C:\WINDOWS\system32\cmP11.dll

Bit4ID - C:\WINDOWS\system32\bit4ipki.dll


За macOS

OpenSC - /Library/OpenSC/lib/opensc-pkcs11.so

Bit4ID - /Library/bit4id/pkcs11/libbit4ipki.dylib

Siemens - /usr/local/lib/libsiecap11.dylib


За Linux

OpenSC - в зависимост от дистрибуцията, която използвате може да е на някое от следните места:

  • 64 битови базирани на Debian дистрибуции (Debian, Ubuntu, Mint) - /usr/lib/x86_64-linux-gnu/opensc-pkcs11.so
  • 32 битови базирани на Debian дистрибуции (Debian, Ubuntu, Mint) - /usr/lib/i386-linux-gnu/opensc-pkcs11.so
  • Стари версии на Debian/Ubuntu и 32 битови версии на RedHat/Fedora - /usr/lib/opensc-pkcs11.so
  • 64 битови версии на RedHat/Fedora - /usr/lib64/opensc-pkcs11.so

Bit4ID

  • Стандатрно местоположение - /usr/lib/libbit4ipki.so
  • 64 битови версии на RedHat/Fedora - /usr/lib64/libbit4ipki.so

Siemens - /usr/local/lib/libsiecap11.so